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INTRODUCTION

General description
The software Patchwork Explorer offers an interactive presentation of 3D Digital Aspect Mockups
created with the Patchwork 3D authoring software, as well as the exploration of product configurations.
This program is designed to be simple and requires no knowledge of 3D rendering.

Patchwork Explorer provides a 3D visualization space called a “Viewport” that allows you to interac-
tively inspect a product’s design. Tools such as the real-time sun contribute to the creation of an
ultra-realistic appearance.

Several viewport configurations [10] are available for viewing products side by side. This approach
allows several elements in a range of products to be compared at the same time. The ability to link
viewports [16] is included to facilitate comparisons in 3D.

Objective
We will explore how to compare two products within Patchwork Explorer. In this tutorial, we will
review each step in this process, from importing a Patchwork 3D database to creating a real-time
multi-kdr presentation. We will also describe a few features for using a real-time sun in your product
presentation.
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IMPORTING PRODUCTS

The first step consists of loading into Patchwork Explorer the KDR file previously created in Patchwork
3D Enterprise in which are located the different products you want to compare.

To do this, go to the File menu, click on Open or use Ctrl + L keys, then load the KDR file you want to
use.

NOTE
For this tutorial, we will use the AeroSeat.kdr database which you can download here.

Open a KDR file in Patchwork Explorer.

The floating Viewport Manager window will appear on the screen. This window displays the list of
products contained in the imported database, but also the functionalities relating to the products, the
organization of the views, as well as the positioning of the observation point.

Floating Viewport Manager window.
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TIP
It is possible to show or hide this window from the Viewport Manager in the Editors menu
from the main window or via the keyboard shortcut M.
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OPENING A PRODUCT IN THE MAIN WINDOW

You can open a product in the 3D viewport by double-clicking on the product thumbnail or by dragging
and dropping the thumbnail into the 3D viewport space of the main window.

Open the product named AeroSeat Blue. The product is then displayed in the maximized view (1x1)
from the main window. We will see later how to change to a multi-view configuration to facilitate the
comparison of several products.

Product opened in a single maximized viewport (1×1).
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USING NAVIGATION TOOLS

To display even the smallest details of a product, Patchwork Explorer includes a range of navigational
tools. These tools are available in the Viewport Manager or in the Mode menu in the main window.

From the view manager.

From the Mode menu.

The product is always observed from a freely-defined point of view. These tools will help you position
this observational point as efficiently and precisely as possible.

The look-at point determines the direction in which the camera is directed. The observational point
designates the location of the camera in the scene.

The available navigational tools are listed in the following table:

Icon Tool Description
Select A product in the scene can be selected by clicking on it. The corners

of a box enclosing the selected product appear. This indicates which
product is included in the selection. 

Zoom The look-at point remains fixed and the observational point shifts along
the direction of observation.
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Icon Tool Description
Pan The observer moves laterally along the observation plane.

Orbit The observational point revolves around a fixed look-at point.

Fly Mode The look-at point and the observational point both advance in the direc-
tion of observation.

Walk Mode The look-at point and the observational point both advance in the di-
rection of observation, but the observational point remains at a fixed
altitude.

Focal This mode reproduces the setting of the focal length of a camera.

Roll The product turns with regard to the center of the screen.

Zoom to fit The observational point is positioned in order to show the entirety of the
product while preserving the direction of observation.

Collisions The camera’s ability to pass through all surfaces in a scene is blocked
when this option is activated. To observe the effects of this option, use
fly mode or walk mode.

Prevent Col-
lisions with
Transparent
Surfaces

The camera’s ability to pass through transparent surfaces only is activa-
ted. (Available only if Collisions is activated.)

NOTE
Keyboard shortcuts allow quick access to the first three navigational modes:

• Zoom: Ctrl + Shift + Middle Mouse Button / move the mouse

• Pan : Middle Mouse Button / Move

• Orbit: Ctrl + Middle Mouse Button / move the mouse

Use Ctrl+Space to place the viewport’s look-at point at the position indicated by the mouse pointer.

Use Shift+Space to set the depth of field and bring the surface under the mouse pointer into focus.
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COMPARE MULTIPLE PRODUCTS

The main function of Patchwork Explorer is the comparison of different versions of your products.
Patchwork Explorer provides the tools that allow the main viewport to be divided into several viewports,
all while preserving the real-time interactivity of each viewport.

Tools for configuring predefined views are accessible from the View manager or from the menu View >
Configuration from the main window.

From the View Manager.

From the View menu.

To illustrate this, we will compare the product AeroSeat Blue at AeroSeat Peach.
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1. First click on the view button 2X1 in the View manager.

View button 2 × 1.

2. Then drag / drop the product thumbnail AeroSeat Peach in the right part of the 3D viewing area.
Both products are then displayed in the main window.

2 × 1 view.

You can use the other predefined view configurations depending on the type and number of
products you want to compare.
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3 × 1 view.
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CREATING A SNAPSHOT

During the presentation of your product in Patchwork Explorer, you can at any moment create a
snapshot that maintains the format, framing and composition of the active view. The image created
(formats: jpg, bmp, png) is then saved in the file of your choice. Snapshot features to create anima-
tions, VR objects or VR cube panoramas are also available.

In our case, we will create a shot of the AeroSeat Peach product so that the framing of the image
highlights the fabric of the seat.

1. Start by selecting the view containing the AeroSeat Peach product.

The view containing the AeroSeat Peach product is framed in white: this is the active view.

2. Use the navigation tools to move the point of interest so that the seat back is framed in the image.
Use the command Ctrl + Space on the handle to control the point of interest more easily.
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You may notice that the movement of the observation point of the active view is instantly reflected
in the other views of the main window. We will see in the next chapter the possibilities of interac-
tive links between the different views.

Seat fabric highlights.
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3. Finally, click the Snapshot Image entry in the Editors menu to save the image to the folder you want.
Name the image AeroSeat Peach by specifying the JPG extension, then click on the Save button.
Click the Render button to snapshot.

The Snapshots Editor.

NOTE
The generated image has the same dimensions as the active view in Patchwork Explorer.
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LINKING VIEWPORTS

Access: Viewport menu > Link

To facilitate the comparison of products shown in different viewports, Patchwork Explorer employs
a method of synchronization of multiple viewports (interactive comparison). If this linking method is
active, the observational point in the inactive viewports will be updated to correspond to any modifica-
tions to the observational point in the active viewport.

You can choose from different link modes:

Icon Mode Description
None The observational point is never updated.

All The observational point is always updated in all viewports.

Model The observational point is updated in viewports with the same model. All
of the products based on the same model are updated to be viewed from
the same position.

Link Inter-
actively

This option allows the observational point to be dynamically and instan-
taneously synchronized in accordance with the chosen link mode.

For complex scenes, this interactive synchronization hinders the fluidity of movement. When the
Link Interactively option is deactivated, the synchronization takes effect once the interactive phase of
modification has ended.

NOTE
The default link settings use the Model mode and the Link Interactively option is deactiva-
ted.

Patchwork Explorer Community 2022 X5

16



EXPLORING PRODUCT CONFIGURATION

Accessible: Editors menu > Product Manager

Patchwork Explorer takes advantage of product configuration if it is present in the imported KDR file.
The software thus offers the ability to easily explore all of the possible product combinations.

Configuration tab of the Product Manager editor.

Configuration settings are displayed when the active product has configurable elements. To change the
product configuration, modify these settings using the checkboxes and the drop-down lists.
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USING A REAL-TIME SUN

The Real-Time Sun Editor offers features to set up and display a sun, which is editable in real-time, in
your products. Depending on your license options, the real-time sun may not be available.

We are going to use one of the three real-time sun adjustment methods, the manual positioning
method. The other two methods are described in the Patchwork 3D Enterprise user manual.

NOTE
We will use for this tutorial the lego-technics.kdr file which you can download here.

Open the lego-technics.kdr file, then drag-and-drop the product from the toolbox to the main window.
The Real-time Sun Editor is accessible from the menu Editors >  Real-Time Sun Editor.

The Real-Time Sun Editor.

Check the On box to enable the real-time sun. Set the sun intensity by enteringthe desired value in
the Intensity field of the Sun Settings box directly.
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Example of renderings with an intensity value of 1 on the left and 0.2 on the right.

Select the desired Shadow smoothness using the drop-down menu in the Shadow settings box.

Example of renderings with shadow smoothness set to None on the left and Large on the right.

Next, set the angle between the X axis of your database and the desired north direction: click on the
compass and move it to the desired position while holding down the mouse button. You may also enter
a value directly in the corresponding field. Setting the north allows you to stage your product more real-
istically. To display the axis of your database, use the Axis Orientation feature of the Visualization menu.

An angle of 90⁰ has been set between the X axis and the north direction.
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Samples of rendering for different Azimuth and Altitude values.

In order to position the sun manually, you have to set the Azimuth and Altitude values. Using the mouse,
bring the arrows directly to the desired positions. You may also enter a value in the corresponding
fields.
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HELP

You can find this tutorial in the menu Help > Tutorial.

NOTE
A support and training service is also available. For any further information, please visit
our forum https://forum.patchwork3d.com/ or contact us at the following address: sup-
port@lumiscaphe.com.
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