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INTRODUCTION

General description

The software Patchwork Explorer offers an interactive presentation of 3D Digital Aspect Mockups
created with the Patchwork 3D authoring software, as well as the exploration of product configurations.
This program is designed to be simple and requires no knowledge of 3D rendering.

Patchwork Explorer provides a 3D visualization space called a “Viewport” that allows you to interac-
tively inspect a product’s design. Tools such as the real-time sun contribute to the creation of an
ultra-realistic appearance.

Several viewport configurations [11] are available for viewing products side by side. This approach
allows several elements in a range of products to be compared at the same time. The ability to link
viewports [17] is included to facilitate comparisons in 3D.

Objective

We will explore how to compare two products within Patchwork Explorer. In this tutorial, we will
review each step in this process, from importing a Patchwork 3D database to creating a real-time
multi-kdr presentation. We will also describe a few features for using a real-time sun in your product
presentation.
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IMPORTING PRODUCTS

The first step consists of loading into Patchwork Explorer the KDR file previously created in Patchwork
3D Enterprise in which are located the different products you want to compare.

To do this, go to the File menu, click on Open or use Ctrl + L keys, then load the KDR file you want to
use.

¢ NOTE

For this tutorial, we will use the AeroSeat.kdr database which you can download here.

The floating Viewport Manager window will appear on the screen. This window displays the list of
products contained in the imported database, but also the functionalities relating to the products, the
organization of the views, as well as the positioning of the observation point.

E AeroSeat - AeroSeat Blue - Patchwaork Explorer Viewport Manager >



https://resources.lumiscaphe.com/Resources/P3D_Explorer/AeroSeat.kdr
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TIP

It is possible to show or hide this window from the Viewport Manager in the Editors menu
from the main window or via the keyboard shortcut M.
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OPENING A PRODUCT IN THE MAIN WINDOW

You can open a product in the 3D viewport by double-clicking on the product thumbnail or by dragging
and dropping the thumbnail into the 3D viewport space of the main window.

Open the product named AeroSeat Blue. The product is then displayed in the maximized view (7x7)
from the main window. We will see later how to change to a multi-view configuration to facilitate the
comparison of several products.

& AeroSest Blue - Lumiscaphe Patchwork Explorer v2021.1 X5 release 1 64 bits - O X
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USING NAVIGATION TOOLS

To display even the smallest details of a product, Patchwork Explorer includes a range of navigational
tools. These tools are available in the Viewport Manager or in the Mode menu in the main window.

* Selection

The product is always observed from a freely-defined point of view. These tools will help you position
this observational point as efficiently and precisely as possible.

The look-at point determines the direction in which the camera is directed. The observational point
designates the location of the camera in the scene.

The available navigational tools are listed in the following table:
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Icon

m

Tool
Select

Zoom

Pan

Orbit

Fly Mode

Walk Mode

Translation
gizmo

Rotation
gizmo

Focal

Roll

Zoom to fit

Collisions

Prevent
Collisions
with Trans-
parent Sur-
faces

Description

A product in the scene can be selected by clicking on it. The corners of a
box enclosing the selected product appear. This indicates which product
is included in the selection. With the "Layout” license option, multiple
products can be selected at once.

The look-at point remains fixed and the observational point shifts along
the direction of observation.

The observer moves laterally along the observation plane.
The observational point revolves around a fixed look-at point.

The look-at point and the observational point both advance in the direc-
tion of observation.

The look-at point and the observational point both advance in the direc-
tion of observation, but the observational point remains at a fixed alti-
tude.

& NOTE

This feature requires the "Layout” license option.

The product (or group of selected products) can be positioned by direct
manipulation of the translation gizmo.

& NOTE

This feature requires the "Layout” license option.

The product (or group of selected products) can be oriented by direct
manipulation of the rotation gizmo.

This mode reproduces the setting of the focal length of a camera.
The product turns with regard to the center of the screen.

The observational point is positioned in order to show the entirety of the
product while preserving the direction of observation.

The camera’s ability to pass through all surfaces in a scene is blocked
when this option is activated. To observe the effects of this option, use
fly mode or walk mode.

The camera’s ability to pass through transparent surfaces only is activa-
ted. (Available only if Collisions is activated.)
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¢ NOTE

Keyboard shortcuts allow quick access to the first three navigational modes:

« Zoom: Ctrl + Shift + Middle Mouse Button / move the mouse
* Pan: Middle Mouse Button / Move
* Orbit: Ctrl + Middle Mouse Button / move the mouse

Use Ctrl+Space to place the viewport's look-at point at the position indicated by the mouse pointer.

Use Shift+Space to set the depth of field and bring the surface under the mouse pointer into focus.

10
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COMPARE MULTIPLE PRODUCTS

The main function of Patchwork Explorer is the comparison of different versions of your products.
Patchwork Explorer provides the tools that allow the main viewport to be divided into several viewports,
all while preserving the real-time interactivity of each viewport.

Tools for configuring predefined views are accessible from the View manager or from the menu View >
Configuration from the main window.

To illustrate this, we will compare the product AeroSeat Blue at AeroSeat Peach.

11
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1. First click on the view button 2X7 in the View manager.

2. Thendrag / drop the product thumbnail AeroSeat Peach in the right part of the 3D viewing area.
Both products are then displayed in the main window.

& Acroseat Peach - Lumiscaphe Patchwork Explorer v2021.1 X3 release 164 bits - o x

You can use the other predefined view configurations depending on the type and number of
products you want to compare.

12
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B Acroseat Cream - Lumiscaphe Patchwork Explorer v2021.1 X5 release 1 64 bits - o x

3 x 1 view.

13
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CREATING A SNAPSHOT

During the presentation of your product in Patchwork Explorer, you can at any moment create a
snapshot that maintains the format, framing and composition of the active view. The image created
(formats: jpg, bmp, png) is then saved in the file of your choice. Snapshot features to create anima-
tions, VR objects or VR cube panoramas are also available.

In our case, we will create a shot of the AeroSeat Peach product so that the framing of the image
highlights the fabric of the seat.

1. Start by selecting the view containing the AeroSeat Peach product.

B AcroSeat Peach - Lumiscaphe Patchwork Explorer v2021.1 X5 release 1 64 bits - o b

The view containing the AeroSeat Peach product is framed in white: this is the active view.

2. Use the navigation tools to move the point of interest so that the seat back is framed in the image.
Use the command Ctrl + Space on the handle to control the point of interest more easily.

14
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You may notice that the movement of the observation point of the active view is instantly reflected
in the other views of the main window. We will see in the next chapter the possibilities of interac-
tive links between the different views.

[& AeroSeat Peach - Lumiscaphe Patchwork Explorer v2021.1 X5 release 1 64 bits - O b

Seat fabric highlights.

15
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Finally, click the Snapshot Image entry in the Editors menu to save the image to the folder you want.
Name the image AeroSeat Peach by specifying the JPG extension, then click on the Save button.
Click the Render button to snapshot.

4 Snapshots >

& NOTE

The generated image has the same dimensions as the active view in Patchwork Explorer.

16
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LINKING VIEWPORTS

Access: Viewport menu > Link

To facilitate the comparison of products shown in different viewports, Patchwork Explorer employs

a method of synchronization of multiple viewports (interactive comparison). If this linking method is
active, the observational point in the inactive viewports will be updated to correspond to any modifica-
tions to the observational point in the active viewport.

You can choose from different link modes:

Icon Mode Description
None The observational point is never updated.

All The observational point is always updated in all viewports.

of the products based on the same model are updated to be viewed from
the same position.

Link Inter- This option allows the observational point to be dynamically and instan-
actively taneously synchronized in accordance with the chosen link mode.

. Model The observational point is updated in viewports with the same model. All

For complex scenes, this interactive synchronization hinders the fluidity of movement. When the
Link Interactively option is deactivated, the synchronization takes effect once the interactive phase of
modification has ended.

£ NOTE

The default link settings use the Model mode and the Link Interactively option is deactiva-
ted.

17
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COMBINING PRODUCTS

¢ NOTE

This feature requires the "Layout” license option.

Patchwork Explorer provides the option of staging several products to compare them in the same view.
In this way, you can assess the differences between each product when they are placed in the same
environment.

You are free to add as many products as you want in the same view, only the technical characteristics
of your graphics card can limit the number of products open in a view.

TIP

Adding models to a view is not limited to products contained in a database, you can
enrich your scene by including products from different databases (see "Multi-KDR [20]"
chapter for more details).

Hold down the Ctrl key while dragging and dropping the AeroSeat Cream product thumbnail in the view
where the AeroSeat Peach product is located. The two products are then displayed in the same view.

B AeroSeat Blue - Lumiscaphe Patchwork Explorer v2021,1 X5 release 164 bits - O ®

B Acrosest - AeroSeat Cresm - Patchwaork Explorer Viewport Manager X

18
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MULTI-KDR

Opening several KDR files is possible thanks to the “multi-KDR” mode in Patchwork Explorer.

With the “multi-KDR” mode, you can add products from other databases to the list of products available
in the Viewport Manager.

When the "multi-KDR" mode is deactivated, the list of products available in the View Manager is limited
to the products in your KDR file. Once the "multi-KDR" mode is activated, you can add products from

other databases to this list.

This gives you the possibility to stage together or compare side by side products found in different KDR
files.

To add products from a different database, return to the File menu to open a new database. Products in
this new database will be added to the list of products available in the Viewport Manager.

E AeroSeat - AeroSeat Blue - Patchwork Explorer Viewport Manager ? X

¢ NOTE

This feature requires the "Layout” license option.

In a view 3X7 open the product AeroSeat Blue, then the product BAG, finally create a combination of
products using the operation Ctrl + Drag & Drop.

20
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B Aeroseat Blue - Lumiscaphe Patchwork Explorer v2021.1 X5 release 164 bits - o x

You have the possibility to arrange the products as you wish by intervening on the translation and
rotation parameters of each product.

In the menu Editors click on the entry Product management. Select a product to position in the list of
products in the active view. Then enter the new transformation values. These transformations can also
be edited directly by manipulating the translate and rotate gizmos.

These can be activated respectively by means of the buttons. Bl and @ of the Transformations box.

w2021.1 X5 release 1 64 bits

21
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& Product Manager ? >

22
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EXPLORING PRODUCT CONFIGURATION

Accessible: Editors menu > Product Manager

Patchwork Explorer takes advantage of product configuration if it is present in the imported KDR file.
The software thus offers the ability to easily explore all of the possible product combinations.

& Product Manager >

Configuration settings are displayed when the active product has configurable elements. To change the
product configuration, modify these settings using the checkboxes and the drop-down lists.

24
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Combining products is also possible with configurable products (see chapter on “Combining Prod-

ucts [18]"). With the "Layout” license option, you can place a configurable product with multiple
instances in a viewport and configure each of these products independently of each other. You can
compose your scene with several variations of the same product or compare these different versions in
separate viewports (see chapter on “Comparing Multiple Products [11]").

25
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USING A REAL-TIME SUN

The Real-Time Sun Editor offers features to set up and display a sun, which is editable in real-time, in
your products. Depending on your license options, the real-time sun may not be available.

We are going to use one of the three real-time sun adjustment methods, the manual positioning
method. The other two methods are described in the Patchwork 3D Enterprise user manual.

& NOTE

We will use for this tutorial the lego-technics.kdr file which you can download here.

Open the lego-technics.kdr file, then drag-and-drop the product from the toolbox to the main window.
The Real-time Sun Editor is accessible from the menu Editors > Bl Real-Time Sun Editor.

B Rreal-Time sun *

Check the On box to enable the real-time sun. Set the sun intensity by enteringthe desired value in
the Intensity field of the Sun Settings box directly.

26
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Select the desired Shadow smoothness using the drop-down menu in the Shadow settings box.

Next, set the angle between the X axis of your database and the desired north direction: click on the

compass and move it to the desired position while holding down the mouse button. You may also enter
a value directly in the corresponding field. Setting the north allows you to stage your product more real-
istically. To display the axis of your database, use the Axis Orientation feature of the Visualization menu.

27
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In order to position the sun manually, you have to set the Azimuth and Altitude values. Using the mouse,
bring the arrows directly to the desired positions. You may also enter a value in the corresponding
fields.

28
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HELP

You can find this tutorial in the menu Help > Tutorial.

¢ NOTE

A support and training service is also available. For any further information, please visit
our forum https://forum.patchwork3d.com/ or contact us at the following address: sup-
port@lumiscaphe.com.

29
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